UPDATED: Critical Vulnerability in Apple iOS and OS X

UPDATED: 03/04/14

A patch for  Macs [OS X] has now been released by Apple.  Follow the instructions below to update your system.

Apple revealed a major vulnerability in its software that affects its devices, allowing hackers to intercept and alter communications such as email and login credentials.  Apple released a patch for iOS on Friday.  The vulnerability has been confirmed in iOS versions 6.1.5, 7.0.4, and 7.0.5, and OS X 10.9.0 and 10.9.1. Security researchers haven’t ruled out the possibility that earlier versions are also affected. Users should immediately update their iPhones and iPads to versions 7.0.6 or 6.1.6, preferably using a non-public network.

To patch your device(s):

  • Run “Software Update“ from your device’s “settings” menu   – OR -
  • Connect your device to your personal computer, open iTunes, select the device you just connected, and click the “Check for update” button.

For more details, see these articles:

http://arstechnica.com/security/2014/02/extremely-critical-crypto-flaw-in-ios-may-also-affect-fully-patched-macs/

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-1266&cid=2